Question: unable to permanently delete a dataset from Galaxy
0
gravatar for Laura.Collins
3.7 years ago by
Laura.Collins • 0 wrote:

I have deleted some galaxy datasets to free up memory.  I would like to permanently delete them but when I select this option I get an error message in red saying:

Unable to purge dataset.  Please contact a Galaxy administrator if the problem persists.

I've tried logging out and back in again but I still can't permanently delete any unwanted dataset.  I'm not sure how to contact a Galaxy administrator.  Any help would be appreciated.

 

software error galaxy • 1.6k views
ADD COMMENT • link • modified 3.7 years ago by Dannon Baker ♦ 3.7k • written 3.7 years ago by Laura.Collins • 0

Can you tell me exactly how you went about trying to purge the datasets?  (which menu, etc.)

ADD REPLY • link written 3.7 years ago by Dannon Baker ♦ 3.7k

Under the current history I deleted the datasets that I no longer needed by clicking the delete option.  I then selected the deleted link to view all datasets including deletions.  I selected the option to remove the datasets permanently from the disk.

ADD REPLY • link written 3.7 years ago by Laura.Collins • 0

Are you still seeing this behavior today?

ADD REPLY • link written 3.7 years ago by Dannon Baker ♦ 3.7k

It appears to be deleting permanently as expected right now.  I've managed to delete 2 histories that were taking up space, however, the available space hasn't adjusted to reflect this. 

ADD REPLY • link written 3.7 years ago by Laura.Collins • 0

I've just seen that the memory has increased so perhaps it takes a while.  Thanks for the help!

ADD REPLY • link written 3.7 years ago by Laura.Collins • 0

Happy to help - I manually recalculated things and you should be good to go now.

ADD REPLY • link written 3.7 years ago by Dannon Baker ♦ 3.7k
1
gravatar for Dannon Baker
3.7 years ago by
Dannon Baker ♦ 3.7k
United States
Dannon Baker ♦ 3.7k wrote:

Just to leave an actual answer for posterity, the issues with deleting datasets were likely due to a configuration issue on usegalaxy.org that has since been resolved.

ADD COMMENT • link modified 3.7 years ago • written 3.7 years ago by Dannon Baker ♦ 3.7k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 169 users visited in the last hour