Question: Galaxy Docker problem with Database execution
1
gravatar for niras.94
15 months ago by
niras.94 • 30
niras.94 • 30 wrote:

Hello,

I am trying to setup a Galaxy Docker instance but i am getting this error on database startup:

"Connection refused Is the server running on host "localhost" (127.0.0.1) and accepting TCP/IP connections on port 5432? could not connect to server: Network is unreachable Is the server running on host "localhost" (::1) and accepting TCP/IP connections on port 5432?"

Have you any idea??

Thanks a lot,

Dimitris

ADD COMMENT • link • modified 15 months ago by danielsauceda • 60 • written 15 months ago by niras.94 • 30

I personally have not tried Galaxy Docker but here's a couple of things.

  1. What version of Postgresql did you install
  2. what OS are using?
ADD REPLY • link written 15 months ago by danielsauceda • 60
1

I am using Postegresql 9.3 and Ubuntu 14.04.

ADD REPLY • link written 15 months ago by niras.94 • 30

Are you positive that your postgres is running.

sudo service postgresql status

Also verify that in file /etc/postgresql/9.3/main/postgresql.conf has the following line

port = 5432
ADD REPLY • link written 15 months ago by danielsauceda • 60

Postgresql automatically starts when Galaxy Docker is running, so it is not installed locally on pc. The port is 5432 and the .conf file is placed in Galaxy Docker folder.

ADD REPLY • link written 15 months ago by niras.94 • 30
1
gravatar for danielsauceda
15 months ago by
Texas A&M
danielsauceda • 60 wrote:

Yes i have recreated your problem.

If you are using docker in interactive mode postgres does not automatically startup. by running sudo service postgresql status i was able to see that my postgres was indeed not started.

Hence i simply ran sudo service postgresql status and followed that up with ./run.sh in galaxy-central an Tada.

Worked just fine.

If this works for you let me know.

ADD COMMENT • link written 15 months ago by danielsauceda • 60
1

Solved, Thanks a lot!

ADD REPLY • link written 15 months ago by niras.94 • 30

don't forget accept solution :)

ADD REPLY • link written 15 months ago by danielsauceda • 60
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 177 users visited in the last hour