Question: Issue installing Galaxy on a local server for a multi-user production environment
0
gravatar for gkuffel22
19 months ago by
gkuffel22 • 170
United States
gkuffel22 • 170 wrote:

Hi everyone,

We are installing Galaxy on our local server for a multi-user production environment using:

git clone -b release_17.01 https://github.com/galaxyproject/galaxy.git

The error we get is:

./scripts/common_startup.sh: line 122: .venv/bin/activate: No such file or directory

Can anyone provide some help here??

software error galaxy • 574 views
ADD COMMENT • link • modified 19 months ago by Martin Čech ♦♦ 4.9k • written 19 months ago by gkuffel22 • 170
1

I am working with Gina on this. I can get the release fine. I just cannot do anything after that. When I try to run sh run.sh, that is when I get that error.

Let me add that I am using CentOS 6.7 along with the version 2.6.6 of Python (since yum needs it). When logged on as a galaxy user, I have .bashrc pointing to version 2.7.12 of python. When I type python --version, I do get the new version of Python.

As soon as I run sh run.sh (As a NON-ROOT user), I get the following output:

[galaxy@HSDMongo1 galaxy]$ Fetching https://pypi.python.org/packages/source/v/virtualenv/virtualenv-13.1.2.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1679k  100 1679k    0     0  1720k      0 --:--:-- --:--:-- --:--:-- 1775k
Verifying /tmp/galaxy-virtualenv-CIYlx7/virtualenv-13.1.2.tar.gz checksum is aabc8ef18cddbd8a2a9c7f92bc43e2fea54b1147330d65db920ef3ce9812e3dc
Traceback (most recent call last):
  File "/tmp/galaxy-virtualenv-CIYlx7/virtualenv-13.1.2/virtualenv.py", line 2363, in <module>
    main()
  File "/tmp/galaxy-virtualenv-CIYlx7/virtualenv-13.1.2/virtualenv.py", line 832, in main
    symlink=options.symlink)
  File "/tmp/galaxy-virtualenv-CIYlx7/virtualenv-13.1.2/virtualenv.py", line 994, in create_environment
    site_packages=site_packages, clear=clear, symlink=symlink))
  File "/tmp/galaxy-virtualenv-CIYlx7/virtualenv-13.1.2/virtualenv.py", line 1192, in install_python
    copy_required_modules(home_dir, symlink)
  File "/tmp/galaxy-virtualenv-CIYlx7/virtualenv-13.1.2/virtualenv.py", line 1130, in copy_required_modules
    dst_filename = change_prefix(filename, dst_prefix)
  File "/tmp/galaxy-virtualenv-CIYlx7/virtualenv-13.1.2/virtualenv.py", line 1095, in change_prefix
    (filename, prefixes)
AssertionError: Filename /data/apps/Python-2.7.12/Lib/os.py does not start with any of these prefixes: ['/usr/local']

[1]+  Exit 1                  ./run.sh
ADD REPLY • link written 19 months ago by jkoral • 100
1

-I then downloaded the virtualenv.py file wget http://bitbucket.org/ianb/virtualenv/raw/tip/virtualenv.py Then python virtualenv.py --no-site-packages virtual_env And get

[galaxy@HSDMongo1 galaxy]$ python virtualenv.py --no-site-packages virtual_env
Traceback (most recent call last):
  File "virtualenv.py", line 1649, in <module>
    main()
  File "virtualenv.py", line 558, in main
    prompt=options.prompt)
  File "virtualenv.py", line 647, in create_environment
    site_packages=site_packages, clear=clear))
  File "virtualenv.py", line 771, in install_python
    copy_required_modules(home_dir)
  File "virtualenv.py", line 725, in copy_required_modules
    dst_filename = change_prefix(filename, dst_prefix)
  File "virtualenv.py", line 710, in change_prefix
    (filename, prefixes)
AssertionError: Filename /data/apps/Python-2.7.12/Lib/os.py does not start with any of these prefixes: ['/usr/local']
ADD REPLY • link written 19 months ago by jkoral • 100
0
gravatar for Martin Čech
19 months ago by
Martin Čech ♦♦ 4.9k
United States
Martin Čech ♦♦ 4.9k wrote:

Do you have custom build Python? If so this thread on SO might be similar to what you are experiencing. This has most probably nothing to do with Galaxy.

ADD COMMENT • link written 19 months ago by Martin Čech ♦♦ 4.9k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 172 users visited in the last hour